How To Fix the “Expired or not-yet-valid certificate” Security Error Message in Internet Explorer or Firefox When Accessing Your Online Learning Portal

When connecting to CSI’s learning portal or Blackboard, users may run into a security error message “Expired or not-yet-valid certificate” popping up on the homepage. The issue is observed by users running Java 7 update 40 or greater on their computer. As a result of this problem, users may no longer be able to use Blackboard functionalities as the browser blocks any further activity by the user. To remedy the problem; please follow the steps in the PDF linked here.
Posted: 15.Jul.2014 in: